Jump to content

Sound connected to AVR is distorted


Recommended Posts

Posted (edited)

Hi all,

 

Allow me to rephrase myself, sorry for the confusing first post

I have a new Samsung smart TV with built-in streaming apps like Netflix and Disney+ etc, I only wanted the sound to pass thru the AVR to get 5.1 channel, but failed.  (My new TV eARC port is only HDMI 2.0b according to some TV reviews website.)
- sound is distorted, even if the source is TV, the result is the same.

My connect as below:
TV(eARC) -> AVR (ARC)
- all using existing HDMI cable
- Used a new HDMI 2.1 cable and gotten the same unsuccessful result.
- TV settings for "Sound" menu has not much option to change to

 

 

Edited by jkcs
edited "Title" and post to express my problem more specific
Link to post
Share on other sites
  • Replies 23
  • Created
  • Last Reply

Top Posters In This Topic

If you are looking for uncompressed sound formats, you have no choice but get an AVR with eARC

Link to post
Share on other sites
4 hours ago, rayleh said:

If you are looking for uncompressed sound formats, you have no choice but get an AVR with eARC

No, I'm not.  Thanks

Link to post
Share on other sites
Posted (edited)

How is your TV sending audio to your AVR now? Optical cable ?

Edited by Boxerfan88
Link to post
Share on other sites
  • jkcs changed the title to Sound connected to AVR is distorted
On 5/28/2021 at 7:12 AM, Boxerfan88 said:

How is your TV sending audio to your AVR now? Optical cable ?

No, it is via HDMI cable.    thanks

I have edited my original post and title to be more precise

Link to post
Share on other sites

sorry for being so shameless.  haha  😂  

 

Anybody here as similar experience or setup that works?

my TV is a Samung Q60A and a Denon 1911.  Technically HDMI is backward compatible as I done my studies on the internet.

 

It is just that I don't want to buy a new AVR to find out root cause isn't from the old AVR.  tyvm 

Link to post
Share on other sites


You’ll need to share more on your setup and maybe record the sound bro. I don’t think it’s your amp. 

Link to post
Share on other sites
On 5/27/2021 at 3:18 PM, jkcs said:

Hi all,

 

Allow me to rephrase myself, sorry for the confusing first post

I have a new Samsung smart TV with built-in streaming apps like Netflix and Disney+ etc, I only wanted the sound to pass thru the AVR to get 5.1 channel, but failed.  (My new TV eARC port is only HDMI 2.0b according to some TV reviews website.)
- sound is distorted, even if the source is TV, the result is the same.

My connect as below:
TV(eARC) -> AVR (ARC)
- all using existing HDMI cable
- Used a new HDMI 2.1 cable and gotten the same unsuccessful result.
- TV settings for "Sound" menu has not much option to change to

 

 

Hi.

1. Maybe you could elaborate more on what distorted sound meant. Can you still hear the sound correctly, like the dialogue, or it is just you do not get the sound effects expected.

2. Will you be able to connect other source to the another HDMI port or a notebook., then I guess you could determine whether it is the AVR that is causing it.
3. Or you could  use optical from TV to the AVR to see whether that works.
 

Hope it could help

 

Thanks

 

Link to post
Share on other sites
23 hours ago, petetherock said:

You’ll need to share more on your setup and maybe record the sound bro. I don’t think it’s your amp. 

 

21 hours ago, wcseow said:

Hi.

1. Maybe you could elaborate more on what distorted sound meant. Can you still hear the sound correctly, like the dialogue, or it is just you do not get the sound effects expected.

2. Will you be able to connect other source to the another HDMI port or a notebook., then I guess you could determine whether it is the AVR that is causing it.
3. Or you could  use optical from TV to the AVR to see whether that works.
 

Hope it could help

 

Thanks

 

 

Hi Petetherock and wcseow,

 

1) My TV and AVR are connected using HDMI cable via eARC and ARC port respectively.  I just want the native apps e.g Disney+, Netflix to play 5.1 channel thru my HT.

2) Samsung Q60A tv only support Dolby Digital + 

3) Cannot select "Pass-through" under Expert settings for sound mode in TV, see "TV sound settings.jpg"

4) If playing from Netflix/Disney+, the AVR detected as Dolby digital + but the display looks weird and the sound output is distorted, see "TV_netflix.jpg"

a) if I changed the sound settings to PCM, the LCD display and  sound output is like point 5 below

5) If playing from Youtube, the AVR detected as "PLII" , but the sound is only 2.1 channel, see "Youtubejpg.jpg"

 

 

thanks so much for replying to my qns, appreciate alot

TV sound settings.jpg

TV_netflix.jpg

Youtubejpg.jpg

Link to post
Share on other sites
Posted (edited)
1 hour ago, jkcs said:

 

 

 

TV sound settings.jpg

 

 

 

See the text on the RHS, it may explain what is supported, and what isn’t.

 

It seems to say only HDMI sources can be routed via eARC.

 

Does your TV support sending raw audio from apps (NFLX/DSN+) in a passthru fashion via eARC?

 

I donno….

Edited by Boxerfan88
Link to post
Share on other sites

Try "Auto" bro..

Just cycle through the various options to see if the sound gets better.

Your AVR should be able to decode the regular bitstream / PCM options.

 

Link to post
Share on other sites
1 hour ago, petetherock said:

Try "Auto" bro..

Just cycle through the various options to see if the sound gets better.

Your AVR should be able to decode the regular bitstream / PCM options.

 

thanks very much  🙂

 

if select "Auto", the audio output is distorted

Link to post
Share on other sites


×
×
  • Create New...