Jump to content

terfyo

Full Member
  • Content Count

    331
  • Joined

  • Last visited

Community Reputation

0 Neutral

About terfyo

  • Rank
    250+ Post Club
  • Birthday 09/27/1988

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Yeah, it's priced at $398. Kodi comes pre-installed with the device. Haven't got around to play around with and explore that app. Am still figuring out the best position and focus. Doesn't seem to be that sharp, when it's projected at about 4.2 meters.
  2. Just received mine this week, on Monday night (SMART version).
  3. Hi all, interesting read. Really detailed description of the product. I am also interested in getting 2 units of this. Anybody doing MO please also count me in. TIA.
  4. Dear all, I have various equipment from my current setup for sale. 1. Audio Research LS-8 ($1,500.00 obo) Please refer to my ad on carousell in the link as follows for the pictures of the unit https://sg.carousell.com/p/audio-research-ls8-281351413?t-id=633849_1583884843273&t-referrer_request_id=BgBD20AjvnI1RRtt 2. AudioNote AN-J/LX ($2,500.00 obo) Please refer to my ad on carousell in the link as follows for the pictures of the unit; https://sg.carousell.com/p/audio-note-an-j-lx-267187189?t-id=633849_1583884843273&t-referrer_request_id=r2jAqrU0ZiyykIGZ Othe
  5. Nope. It doesn't work.. That only takes a little EMI out of the equation. I think it has something to do with the ground loop. Sent from my SM-N975F using Tapatalk
  6. Dear all, Refer to the link below for my advertisement. https://sg.carousell.com/p/emotiva-upa200-268002371 Looking at (SOLD) / negotiable. Selling because it's a spare amp and not in use. Please contact me @ 9 two two two 1o72 Thanks TL
  7. terfyo

    Amp hum

    Hi Dong, What kind of hum issit? Does it change with volume? Have u tried setting up, with only amp to speakers without any other equipment connected? TL Sent from my SM-N975F using Tapatalk
  8. Hello all gurus, Need some help on this transformer. How should I wire it? I need the output of 280V/0.08A and 6.3V/2A. Please advise starting from the incoming power from the IEC inlet. Thanks in advance. TL Sent from my SM-N975F using Tapatalk
  9. Ar. This i have tried already. I actually switched off all the breakers, leaving only the hifi breaker on (when no one is at home of course), the hum still persist. I've bought a few pieces of ferrite core clips from Koba last weekend, yet to confirm if the hum persists.
  10. Dear all, Have a good looking pair of Thiel CS2.4 for sale @ $2,500.00 negotiable Self-collect and testing @ Hougang. Refer to the link below for pictures of the speakers. https://www.dropbox.com/sh/on7wtorvc6pb64t/AABchR8ClqWAuiPfR4oXaXHna?dl=0 Cabinet Condition 9/10, some slight small nicks here and there due to age. Played only in AC room without smoke and pets. Interested please contact me @ Nine 2two2-1O7two Thanks TL
  11. i do have a balanced transformer which i have custom made by Koba in Chinatown. the transformer helps with approximately -200mV from the reading purely from the socket. Any ways to kinda like, remove this problem of the AC?
  12. favorable. as long as there is an IC connected to another equipment that is ground, it is safe to lift the ground from the power amp. oh btw, i have recently bought the EMI Power Line Tester from an MO and realized that when my airconditioner is not turned on, the reading shows 450mV there about. However, when my AC is turned on, with the compressor cut in, the reading is 1,500mV. That is some real noise there. I have tested almost every other socket in the house and am getting about the same reading. I'm using the Starmex Inverter system. Anybody got any ideas on how to reduce
  13. Yes, have switched out the ICs between pre and amp. Tried both SE and XLR.
  14. Yes. The sockets are grounded properly. I've checked this. I'm now checking with Krell US for then to confirm that cheating the earth at the amp is safe. If they confirm it's safe, then I'll leave it that way. Since all the hum is gone. Sent from my SM-N975F using Tapatalk
  15. I've actually had it checked by a tech who gave it a clean bill of health. Zero hum when tested at his place. But the hums came back when I brought the amp back home and plugged it into my setup. Sent from my SM-N975F using Tapatalk
×
×
  • Create New...